News - SF Project - Overview - Download - Specification - Schedule - Source


First, you will need the Java Runtime Environment, version 1.4 or higher, which you can get here:

Then, you will need the Java3D runtime plugin, which you can get here:
Note: I highly reccomend getting the OpenGL version instead of the DirectX version. In my experiance the performace was vastly better.

Finally, you can download the Arabian Flights .jar file from SourceForge here:

Latest Arabian Flights Jar Files

Depending on the operating system and file associations, some lucky folks can just double click on Jar files to make them run. If that doesn't work, you'll need to run it from the command prompt like this:
java -jar arabian.jar
Of course, you'll need to be in the right directory.

Since AF is 100% java, it should be platform independent. As long as you can get a JRE and the Java3D plugin for your platform, you should be able to run AF. Of course, a 3D accelerator is required as well.

The controls are simple: the mouse is used to look around and the w,s,a,d keys move forward, back, left, and right, respectively. Also you can cycle through the available spells with Q and E. You fire the selected spell with the left mouse button.

Disclaimer: I am in no way responsible for any damage of any sort, at any time, for any reason. Ever. Use the stuff on this page at your own risk.

This page and all of the files it links to are copyright 2002-2003 Mike Prosser